MyBB 1.8.7 brings security and maintenance updates

The MyBB development team released a new version of MyBB 1.8. MyBB 1.8.7 is a maintenance and security update. It does fix 13 security vulnerabilities and 83 reported issues of MyBB 1.8.6.
Beside a lot of low-risk XSS injections, a possible SQL Injection in the moderation tool has been fixed which is declared as medium risk.

You should update your MyBB forum as soon as possible to include these security fixes.

If you are upgrading from MyBB 1.8.6 you can use the changed file package for the upgrade to 1.8.7. Do not forget to make backups first and run the update script after you replaced your old files with the new ones!

You can find the update descriptions on the official MyBB blog.

You should always keep your MyBB at the newest version to prevent hackers from getting access to your forums files and data. If there are security updates you should always update your forum as soon as possible.

This has been the first update that was not released for MyBB 1.6 too, because the support period for MyBB 1.6 has ended. I do expect that MyBB 1.6 does still carry the same security issues as 1.8.6 does. If you are still using MyBB 1.6 it’s the final call to update to 1.8 now.

Leave a Reply

Your email address will not be published.